IgnitionOS4

Offizielles Support- und Diskussionsforum rund um die Tabellenkalkulation ignition
Official support- and discussionforum about the spreadsheet application ignition

Moderatoren: OS4Welt-Team, Ignition-Team

Benutzeravatar
turbo4.1
Ignition-Team
Beiträge: 1752
Registriert: 23. Dezember 2009 18:27
Hat sich bedankt: 9 Mal
Danksagung erhalten: 46 Mal

Re: IgnitionOS4

Beitrag von turbo4.1 »

da es mir etwas zu ruhig im thread geworden ist, werde ich hier mal ein status-report über den stand der arbeiten an beta6 von igniton geben, damit alle wissen das im aos4 sektor noch etwas passiert ;-):

- die funktion QWurzel auf benutzerwunsch implementiert
- maus-rad unterstützung wurde durch Tony Wyatt implementiert. Vielen dank!
- maus-rad unterstützung auch in x-richtung ergänzt.
- funktion ErstelleString auf benutzerwunsch ergänzt.
- fehler im zellen-format dialog korrigiert.
- fehler in den fkt. log10() und ln() korrigiert.
- fehler beim kopieren von blöcken korrigiert.
- fehler im addon für kuchengrafik behoben.
- die funktion anzahl() kann nun auch mit namen umgehen.
- beim schliessen der letzten Tabelle konnte zu einen Grim kommen.
- beim verschieben von diagrammen konnte es zu grafikfehlern kommen.
- lange formeln wurden nicht fehlerfrei gespeichert
- probleme beim aktualisierung mit funktionen die namen benutzen behoben.
- keine probleme mehr mit undo im eingabemodus.
- probleme bei benutzung von datenbanken behoben.

danke an alle benutzer, die diese fehler gemeldet haben!

it is very calm in the last time here in the thread, so i post this status-report about development of beta6 of ignition.
the aos4 software sector is still alive ;-)

- the function sqr is implement after a user request
- mouse-wheel support is implemented by tony wyatt. thanks!
- add the horizontal mouse-wheel support.
- implement function concatenate (add strings) after a user request
- error in cell-format-dialog corrected
- error in fct. ln() and log10() corrected
- wrong behaviour in copy-blocks corrected
- error in addon for pi-diagrams corrected
- the function number() now also works with names.
- remove some problems which maybe calls the grim when closing tables
- no longer graphics-bugs when scrolling diagrams
- no longer problems with very long formulas
- no longer problems with refresh formulas using names
- no longer problems with undo in input-modus
- remove some problems when using databases

thanks to all users, who sent bug-reports!
Sam460ex mit Yeston RX550 4GB (Single Slot, Low Profile), Sam440Flex (666MHz) mit Radeon HD5450 PCI, CDTV mit 270MB SCSI-HD, MemCard, 68010 14MHZ und 5MB RAM, A600 und CD32
Amiga User since 1987
Benutzeravatar
JoTo
Beiträge: 322
Registriert: 21. Januar 2010 12:03
Wohnort: Kurz vor Bremen
Kontaktdaten:

Re: IgnitionOS4

Beitrag von JoTo »

:up:
Klasse, weiter so, ich schaffe momentan nicht so viel, hoffe es wird bald wieder besser !
X5000 2 Ghz, 16Gb, SSD 480 Gb, ATI R9 270 2Gb,
A1000 incl. Vampiere V500 V2+, Amiga 600 HD Furia, SAM440ep-flex 733 Mhz, CDTV
Benutzeravatar
root
Beiträge: 811
Registriert: 3. Oktober 2009 11:21
Wohnort: Berlin
Hat sich bedankt: 28 Mal
Danksagung erhalten: 35 Mal
Kontaktdaten:

Re: IgnitionOS4

Beitrag von root »

Wahnsinn!
X5000 E5500 | 4GB Ram | Radeon R9 270 Windforce | TerraTec 512i :thinking:
Benutzeravatar
turbo4.1
Ignition-Team
Beiträge: 1752
Registriert: 23. Dezember 2009 18:27
Hat sich bedankt: 9 Mal
Danksagung erhalten: 46 Mal

Re: IgnitionOS4

Beitrag von turbo4.1 »

so nun laufen die letzten arbeiten, um die beta6 fertig zu machen, die folgenden änderungen wurden noch eingefügt:
- interne arexx skripte werden nun auch in projekten gespeichert und geladen
- ein weiterer arexx-befehl für datenbanken wurde integriert
- fehler in dialoge korregiert.

now i am working on the last steps to release the beta6, the following changes are added since the last report:
- internal arexx scripte are now saved in project and can also be loaded
- another arexx-xommand for databases is implemented
- errors in dialogs corrected.
Sam460ex mit Yeston RX550 4GB (Single Slot, Low Profile), Sam440Flex (666MHz) mit Radeon HD5450 PCI, CDTV mit 270MB SCSI-HD, MemCard, 68010 14MHZ und 5MB RAM, A600 und CD32
Amiga User since 1987
Benutzeravatar
HelmutH
OS4Welt-Team
Beiträge: 2652
Registriert: 28. September 2009 10:56
Wohnort: Oberhausen
Hat sich bedankt: 42 Mal
Danksagung erhalten: 44 Mal

Re: IgnitionOS4

Beitrag von HelmutH »

@Achim
Da hast du wieder jede Menge Fehler beseitigt und neue Funktionen implementiert, Super :up: .

Hoffe ich habe die beiden Handbücher korrekt aktualisiert und du hast zu dem Fehler den ich
beim Namen ändern der neu definierten Datenbank bekommen habe auch schon eine Idee
warum der Auftritt.
Gruß Helmut
Amiga 500, Amiga 2000, AmigaOne XE, AmigaOne X5000
Benutzeravatar
turbo4.1
Ignition-Team
Beiträge: 1752
Registriert: 23. Dezember 2009 18:27
Hat sich bedankt: 9 Mal
Danksagung erhalten: 46 Mal

Re: IgnitionOS4

Beitrag von turbo4.1 »

die arbeiten an der beta6 sind nun beendet und folgende änderungen sind noch erfolgt:
- korrektur eines fehlers im "datenbank definieren" dialog
- grafikfehler und teilweise seltsame abstürze bei der speziellen "deutschen konfiguration mit neuen iconset"
- abstürze beim beenden und speichern der letzten änderungen.

der punkt zwei ist noch nicht ganz geklärt, warum die konfig-datei diesen fehler enthält. er tritt anscheinend auch nur bei besitztern von radeonhd grafikkarten verstärkt auf. dort erscheinen plötzlich grafikfehler, wie "menue-schatten" die bestehen bleiben. ein tester meldete sogar abstürze beim beenden.
auf rechnern mit radeon9xxxx grafikkarten gibt es nur probleme mit eingebundenen grafiken.
mit den standardicons und der standard-konfig sind die probleme dann nicht mehr vorhanden.
für alle betroffenen gibt es eine funktionierende konfig.datei im support thread.
für rückmeldungen, ob noch mehr benutzer diese probleme haben wäre ich dankbar. Vielleicht hat jemand auch diese auswirkungen mit eigenen erstellten konfiguration!?
dann bitte mit pn oder email melden!

i have finished the work on the beta6 of ignitionOS4, the following last changes are made:
- correction of a error in the "database definition" dialog
- correction of bad grim, when closing ignition and save the last changes
Sam460ex mit Yeston RX550 4GB (Single Slot, Low Profile), Sam440Flex (666MHz) mit Radeon HD5450 PCI, CDTV mit 270MB SCSI-HD, MemCard, 68010 14MHZ und 5MB RAM, A600 und CD32
Amiga User since 1987
Benutzeravatar
HelmutH
OS4Welt-Team
Beiträge: 2652
Registriert: 28. September 2009 10:56
Wohnort: Oberhausen
Hat sich bedankt: 42 Mal
Danksagung erhalten: 44 Mal

Re: IgnitionOS4

Beitrag von HelmutH »

Hi turbo4.1
Sehr gute Arbeit von dir :up:
Wieder ein paar Fehler ausgemerzt, mach weiter so :!: :!: :!:

Werd am Wochenende nochmal weiter testen.
Gruß Helmut
Amiga 500, Amiga 2000, AmigaOne XE, AmigaOne X5000
Benutzeravatar
turbo4.1
Ignition-Team
Beiträge: 1752
Registriert: 23. Dezember 2009 18:27
Hat sich bedankt: 9 Mal
Danksagung erhalten: 46 Mal

Re: IgnitionOS4

Beitrag von turbo4.1 »

die aktuelle beta6 von ignitionOS4 wurde soebend von axel auf der sourceforge-seite zum download bereitgestellt.
viel spass damit... :-)

the actual beta6 of ignitionOS4 is shortly released by axel on the sourceforge-site. you can download it from the files area. much fun with it... :-)
Sam460ex mit Yeston RX550 4GB (Single Slot, Low Profile), Sam440Flex (666MHz) mit Radeon HD5450 PCI, CDTV mit 270MB SCSI-HD, MemCard, 68010 14MHZ und 5MB RAM, A600 und CD32
Amiga User since 1987
Benutzeravatar
HelmutH
OS4Welt-Team
Beiträge: 2652
Registriert: 28. September 2009 10:56
Wohnort: Oberhausen
Hat sich bedankt: 42 Mal
Danksagung erhalten: 44 Mal

Re: IgnitionOS4

Beitrag von HelmutH »

Hab mal gleich ne news auf AF dazu verfasst. :wink:

Super Arbeit von dir , mach weiter so :!: :up:
Gruß Helmut
Amiga 500, Amiga 2000, AmigaOne XE, AmigaOne X5000
Benutzeravatar
HelmutH
OS4Welt-Team
Beiträge: 2652
Registriert: 28. September 2009 10:56
Wohnort: Oberhausen
Hat sich bedankt: 42 Mal
Danksagung erhalten: 44 Mal

Re: IgnitionOS4

Beitrag von HelmutH »

Da es hier wiedermal etwas still geworden ist um das Thema ignition und Achim scheinbar noch mit seinem Küchenumbau beschäfftigt ist, geb ich mal die Info raus das die beta7 an die Tester raus ist und zumindest
ich sagen kann das diese Version sehr stabil läuft. Bei meinen bisherigen Tests hatte ich keine Abbrüche oder
Fehlermeldungen. Also von mir ein :up: für die Arbeit die sich Achim da bisher mit ignition gemacht hat.
Weiter so :!: :!: :!:
Gruß Helmut
Amiga 500, Amiga 2000, AmigaOne XE, AmigaOne X5000
Antworten